如何给centos7下的php7.x安装插件,如:mysqli,zlib

in php with 0 comment

很多人安装wordpress后连接数据库发生错误,原因是php7以后放弃了正常的mysql连接的方法而wordpress还在使用旧的方使进行连接数据库.
这时候就需要安装mysqli来进行数据库的连接.

安装插件方法.
到你解压php-7.1.10的目录下
代码如下

#这里写的是你的解压php7.XX.tar.gz的路径
cd /www/source/php7.1.10/ext
#此处是你需要安装的插件
cd mysqli

接下来需要使用的phpize了(phpize是用来扩展php扩展模块的,通过phpize可以建立php的外挂模块,详细的讲解网上有的,有兴趣了解可以去度娘)。

#在需要安装的插件目录内输入
phpize
./configure
make install

如果phpize指令无效的话可以使用

find / -name phpize
#使用找到的结果
/usr/bin/phpize
./configure
make install

这样插件就会被安装到你的PHP文件内

#找到你的php.ini进行修改
vim /usr/local/server/php/php.ini

图片

注意:php7.1是改为extension=mysqli.so即可而php7.3是要改成extension=mysqli就可以了

修改完ini后重启apache即可生效

service httpd restart

查看localhost/index.php 看看插件是否已经存在